What Are The System Requirements For Waveform?

Follow

Comments

1 comment

  • Rgwynne

    Waveform 8 will not immediately install on Ubuntu 18.04 due to a dependency on libcurl3 which is not compatible with libcurl4.  After a fair bit of digging I have found a solution which works but is a little involved.

    1. The debian package needs to be rebuilt to accept libcurl4 as a dependency
    2. the stock libcurl4 library must be replaced with Evgeny Brazgin's Curl 3 and 4 library that supports both api's
    3. Install the repackaged waveform.deb

    Repackage

    1. Download the waveform debian package [currently 8.2.7]
    2. Open a terminal session and change to your Downloads folder
    3. Run:   sudo dpkg-deb -x Waveform-installer-64bit-linux-8.2.7.deb waveform
    4. Run:   sudo dpkg-deb --control Waveform-installer-64bit-linux-8.2.7.deb waveform/DEBIAN
    5. Edit the file waveform/DEBIAN/control file and change libcurl3 to libcurl4. [save it of course]
    6. Run:  sudo dpkg -b waveform waveformnew.deb

     

    Update libcurl library (https://launchpad.net/~xapienz/+archive/ubuntu/curl34)

    1. sudo add-apt-repository ppa:xapienz/curl34
    2. sudo apt-get update
    3. sudo apt-get upgrade

     

    Install the repackaged waveformnew.deb using your package manager of choice

    1. e.g.  sudo apt install ./waveformnew.deb

    This got me up and running with Waveform 8 on Kubuntu 18.04.  I hope it helps you too

     

     

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk